В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Dedsec08
Dedsec08
21.06.2020 17:07 •  Информатика

Составьте программу нахождения трёхзначного числа , куб суммы цифр которого равен ему самому

Показать ответ
Ответ:
Cfgcyf
Cfgcyf
26.05.2020 00:04

var
a,b,c,n:integer;
begin
for n:=100 to 999 do
begin
a:= n div 100;
b:= n div 10 mod 10;
c:= n mod 10;
if (a+b+c)*(a+b+c)*(a+b+c)=n then writeln(n);
end;
end.

 

и в результате получаем, что это число 512

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота