В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Voproshayka
Voproshayka
22.11.2021 18:43 •  Информатика

Составьте программу, определяющую какое из двух расстояний (S1 или S2) больше при условии, что первое из них вводится в метрах, а второе — в саженях

Показать ответ
Ответ:
alexssrus1
alexssrus1
26.04.2022 02:18

1. Ошибка синтаксиса: пропущен пробел между mod и j в строке while (i modj <> 0) and (i <= lim) do inc(i);

2. В цикле for  не допустимо присваивание переменной счетчика. В данном случае в циклу for i:=1 to LIMIT происходит увеличение переменной на 1: Inc(i)

3. Логическая ошибка. В цикле while надо перебирать делители от числа 2 до lim. Поэтому второе условие (i<=lim) должно быть записано так: (j<=lim). И увеличение переменной же j: Вместо Inc(i) должно быть Inc(j)

4. Неверное условие if (i > lim) необходимо заменить на if (j > lim)

5. В операторе печати надо указать разделитель пробел: write(i, '_');

6. Ошибка синтаксиса: пропущена точка после последнего end.

В итоге программа примет вид:

program test;

const LIMIT = 500;

var i,j, lim: word;

begin

writeln;

for i:=1 to LIMIT do begin

 j:=2;

 lim:=round(sqrt(i));

 while (i mod j <> 0) and (j <= lim) do inc(j);

 if (j > lim) then write(i,' ');

 end;

writeln

end.

Результат выполнения программы:


3. Виправте помилки у програмі Друк простих чисел const LIMIT = 500; var i,j, lim: word; begin write
0,0(0 оценок)
Ответ:
arinaohtova
arinaohtova
14.11.2022 20:00

Реляционная база данных— Наиболее удобным и для пользователя, и для компьютера является представление данных в виде двумерной таблицы - большинство современных информационных систем работает именно с такими таблицами. Базы данных, которые состоят из двумерных таблиц, называются реляционными, (по-английски «relation» - отношение). Основная идея реляционного подхода состоит в том, чтобы представить произвольную структуру данных в виде простой двумерной таблицы.

Структурные элементы - На примере реляционной таблицы рассмотрим основные структурные элементы базы данных.

1.    В реляционных базах данных любые совокупности данных представляются в виде двумерных таблиц (отношений), подобных описанному выше списку учащихся. При этом каждая таблица состоит из фиксированного числа столбцов и некоторого (переменного) количества строк. Описание столбцов принято называть макетом таблицы.

2.    Каждый столбец таблицы представляет поле – элементарную единицу логической организации данных, которая соответствует неделимой единице информации - реквизиту объекта данных (например, фамилия учащегося, адрес).

3. Каждая строка таблицы называется записью. Запись логически объединяет все поля, описывающие один объект данных, например, все поля в первой строке вышеприведенной таблицы описывают данные об учащемся Петрове Иване Васильевиче 12.03.89 рождения, проживающем по адресу ул. Горького, 12-34, обучающемся в 4А классе, номер личного дела - П-69. Система нумерует записи по порядку: 1,2, ..., n, где n - общее число записей (строк) в таблице на данный момент. В отличие от количества полей (столбцов) в таблице количество записей в процессе эксплуатации БД может как угодно меняться (от нуля до миллионов). Количество полей, их имена и типы тоже можно изменить, но это уже особая операция, которая называется изменением макета таблицы.

4.    В структуре записи файла указываются поля, значения которых являются простым ключом, которые идентифицируют экземпляр записи.

5.    Каждое поле может входить в несколько таблиц (например, поле Фамилия может входить в таблицу Список занимающихся в театральном кружке).

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота