В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
029292299292
029292299292
18.02.2021 23:14 •  Информатика

Составьте программу паскаль для нахождения всех счастливых автобусных билетов чтобы из низ извлекался квадратный корень

Показать ответ
Ответ:
sorrypepemain
sorrypepemain
08.10.2020 16:00

Программа, которая сравнивает первые 3 со вторыми 3мя ниже, но я не понял к чему было упоминание корня в первоначальном задании

Program bilet;
var

a,b,c:longint;
i:byte;
begin
writeln('vvrdite nomer');
readln(a);
b:=0;
c:=0;
for i:=1 to 6 do
    if i<4 then begin
       b:=b+(a mod 10);
       a:=a div 10;
       end
    else begin
         c:=c+(a mod 10);
         a:=a div 10;
    end;
if b=c then writeln('schastlivuy ',c,' = ',b)
else writeln('uvyu ',c,' <> ',b);
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота