В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
mariyapetrpet
mariyapetrpet
17.09.2021 04:31 •  Информатика

Составьте программу (паскаль) для решения :

в игре " лото" из мешка случайным образом выбираются бочонки , на каждом из которых написано число от 1 до 50. напишите программу, которая выводит наугад первые 3 выигрышных номера.

Показать ответ
Ответ:
ника2346олл
ника2346олл
10.10.2020 08:21

program Loto;

var

 L: array [1..50] of Integer;

 a: array [1..3] of Integer;

 i, j, n: Integer;

 b: Boolean;

begin

 for i := Low (L) to High (L) do

   L [i] := i;

 Randomize;

 for i := 1 to 3 do begin

   repeat

     n := Random (51) + 1;

   until L[n] <> 0;

   a [i] := L [n];

   L [n] := 0;

 end;

 for i := 1 to 3 do

   Write (a [i], ' ');

 ReadLn;

end

Объяснение:

сделана проверка чтобы 3 числа не совпадали друг с другом

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота