Составьте программу по которой компьютер десять раз запросит ввод целых и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных. паскаль, соответственно.
Var a,b,c,d:integer; begin for a:=1 to 10 do begin write('введите число=> '); readln(d); if (d mod 2=0) then c:=c+1 else d:=d+1; end; writeln('чётных=> ',c,' нечётных=> ',d); end.
begin
for a:=1 to 10 do begin
write('введите число=> ');
readln(d);
if (d mod 2=0) then c:=c+1 else d:=d+1;
end;
writeln('чётных=> ',c,' нечётных=> ',d);
end.
var s,nc,c,i:integer;
begin
for i:=1 to 10 do
begin
read(s);
if odd(s) then inc(nc);
if not odd(s) then inc(c);
end;
writeln('Чётных: ',c,' Не чётных: ', nc);
end.