В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).сделайте три варианта программы,используя операторы while,repeat ,for.

Показать ответ
Ответ:
Nikalusha
Nikalusha
06.10.2020 08:12
Program;
var a,i,sr,k,sum:integer;
k:=0;
sum:=0;
Begin
for i:=1 to 10 do
begin;
read(a);
k:=k+1;
sum:=sum+a;
sr:=sum/k;
end;
write(sr);
End.

Program;
var a,i,k,sum,sr,r:integer;
Begin
k:=0
sum:=0;
r:=0;
repeat
begin;
read(a);
k:=k+1;
sum:=sum+1;
r:=r+1;
until r=10;
sr:=sum/k;
write(sr);
End.

Цикл While  подумай сама,уверен у тебя получится
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота