В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Радость2129
Радость2129
16.04.2023 19:37 •  Информатика

Составьте программу, позволяющую закрасить поле Робота размером 9×9 с использованием процедуры Row

Показать ответ
Ответ:
urbutite71
urbutite71
07.05.2022 23:01
Программа:
const     n = 100;
type    mas = array[1..n] of byte;
var   input: text;   
output: text;   
a: mas;   
count : byte;   
i: byte;   
sum_1, sum_2 : integer;   
n_1, n_2 :byte;   
avrg_1, avrg_2 : real;
begin     
sum_1 := 0;     
sum_2 := 0;     
n_1 := 0;     
n_2 := 0;
assign(input,'in.txt');     
assign(output,'out.txt');     
reset(input);     
rewrite(output);
write('N : ');     
readln(count);         
for i:=1 to count do     
begin         
readln(input,a[i]);         
if i mod 2 = 1 then         
begin           
sum_1 := sum_1 + a[i];           
n_1 := n_1 + 1;         
end         
else
begin           
sum_2 := sum_2 + a[i];           
n_2 := n_2 + 1;         
end     
end;
avrg_1 := sum_1 / n_1;     
avrg_2 := sum_2 / n_2;
writeln(output,avrg_1);     
writeln(output,avrg_2);
close(input);     
close(output);
end.
0,0(0 оценок)
Ответ:
rne
rne
18.12.2022 21:47
Program MinMax
var a: array [1..100] of real
var i, nmin, nmax: integer, min, max: real
BEGIN
for i := 1 to 100 do read a[i]; // вводим массив
min := a[1]; max := a[1]; nmin := 0; nmax := 0;
for i := 1 to 100 do
begin
if a[i] = min then nmin := nmin + 1;
if a[i] = max then nmax := nmax + 1;
if a[i] < min then begin min = a[i]; nmin := 1; end
if a[i] > max then begin max = a[i]; nmax := 1; end
end;
if nmin > nmax then write ('Min')
if nmin < nmax then write ('Max')
if nmin = nmax then write ('Ravno')
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота