В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу проверки эквивалентности двух логических функций. постройте соответствующие таблицы истинности(программно). 1.проверьте что x → y эквивалентна not (x) or y

Показать ответ
Ответ:
inatalia3007
inatalia3007
03.10.2020 02:27
//так и не осознала как вводить функции с клавиатуры. С у учителя.
var b1,b2,b:boolean;

function imp(a, b : boolean) : boolean;
begin
imp:=(not a) or b;
end;

begin;
writeln('Implication');
For b1:=false to true do
For b2:=false to true do
writeln(b1:7,b2:7,imp(b1,b2):7);

writeln('not (x) or y');
For b1:=false to true do
For b2:=false to true do
writeln(b1:7,b2:7,((not b1) or b2):7);

For b1:=false to true do
For b2:=false to true do
if imp(b1,b2)<>((not b1) or b2) then
 begin;
  writeln('Не эквивалентны');
  exit;
 end;
writeln('Эквивалентны');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота