В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Yita
Yita
07.04.2023 07:32 •  Информатика

Составьте программу, проверяющую, является ли последовательность чисел, вводимых с клавиатуры, возрастающей. Язык паскаль, цикл while​

Показать ответ
Ответ:

var n,t:integer;

   b:boolean;

begin

 b:=true;

 readln(t);

 while true do begin

   readln(n);

   if (n=0) then break;

   if n>t then t:=n

   else b:=false;

 end;

 

 if b then writeln('возростающая')

 else writeln('не возростающая')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота