В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Mrmr56
Mrmr56
19.12.2022 22:03 •  Информатика

Составьте программу решения следующей задачи. На день рождения к Алие пришли гости первом классе подарил ей 5 роз, каждый последующий дарил на 4 роз больше. Сколько цветов подарили Алие, если последний гость подарил ей 101 розу​

Показать ответ
Ответ:
dfhjkgftg357
dfhjkgftg357
01.12.2022 09:14

Задача 1

Program Zadanie1;

var i,N:integer;

A:array[1..4]of integer;

Begin

readln(n);

A[1]:=round(int(N/1000));

A[2]:=round(int(N/100))-A[1];

A[3]:=round(int(N/10))-A[1]-A[2];

A[4]:=N-A[1]-A[2]-A[3];

if (A[1]:=A[4]) and (A[2]:=A[3]) and (A[3]:=A[2]) and (A[4]=A[1]) then writeln('полином');

end;

 

Задача 2

Program Zadanie2;

var i,N:integer;

A:array[1..3]of integer;

 

function Kub(a):integer;begin Kub:=a*a*a;end;

 

Begin

readln(n);

A[1]:=round(int(N/1000));

A[2]:=round(int(N/100))-A[1];

A[3]:=N-A[1]-A[2]-A[3];

if N*N=kub(A[1])+kub(A[2])+kub(A[3]) then writeln('равенство');

end;

0,0(0 оценок)
Ответ:
жансая87
жансая87
31.12.2021 19:16

Ниже жирным шрифтом приведен код программы на Паскале. В фигурных скобках обычным шрифтом - комментарии. Можно их оставить - компилятор не сможет их прочитать и программа все равно будет работать.

 

 

program printname;
var first_name, family_name : string;
i : byte;

begin
write('Введи свое имя: ');
readln(first_name); {считываем имя в переменную first_name}
write('Введи свою фамилию: ');
readln(family_name); {считываем фамилию в переменную family_name}
for i := 1 to 10 do writeln(family_name, ' ', first_name); {В цикле for со счетчиком i изменяющимся от 1 до 10 печатаем строки с фамилией и именем через пробел}
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота