Составьте программу с описанием действий (алгоритм)
«Дан массив из целых чисел. Задано число N-количество элементов в массиве (1<=N<=10000). Далее через пробел записаны N чисел-элементы из массива. Паскаль! Необходимо вывести единственное число..С ОБЪЯСНЕНИЕМ,
const n=10;
var
min,i: integer;
a: array[1..n] of integer;
begin
randomize;
min:=11;
for i:=1 to n do begin
a[i]:=random(1,10);
write (a[i],' '); // для наглядности. можно удалить
if (i mod 2 =1) and (a[i]<min)
then min:=a[i];
end;
writeln;
writeln ('min = ',min)
end.
Пример:
5 4 7 8 6 2 10 4 9 9
min = 5
2 задача:
const n=10;
var
max,count,i: integer;
a: array[1..n] of integer;
begin
randomize;
max:=0;
count:=0;
for i:=1 to n do begin
a[i]:=random(1,10);
write (a[i],' '); // для наглядности. можно удалить
if a[i]>max
then max:=a[i];
end;
for i:=1 to n do
if max=a[i] then count:=count+1;
writeln;
writeln ('max = ',max);
writeln ('count = ',count);
end.
Пример:
8 5 3 2 2 10 10 9 3 10
max = 10
count = 3
Семейство маковых - Papaueraceae
Однолетнее травянистое растение до 100 - 120см высоты с крупными одиночными цветками, лепестки белого цвета с фиолетовым глазком. Стебель прямой. Листья крупные, яйцевидные. Плод - шаровидная или овально - продолговатая коробочка с семенами. Цветет в июне - августе, плоды созревают в августе - сентябре.
Размножаются семенами.
Используют в медицине зрелые(сухие) коробочки со стеблем до 40 см, собираемые в период созревания семян. Из мака приготавливают обезболивающие препараты и антиспазматическое средство.
Мак выращивается в СССР в Казахстане, Киргизии, на Украине и в Поволжье.
Маки представлены однолетними, двулетними и многолетними растениями. Зимостойкие, светолюбивые, они предпочитают легкие богатые гумусом почвы, содержащие известь. Цветут 2–3 дня. Однолетние маки, срезанные с чуть треснувшими бутонами и сразу опущенные в воду, цветут дольше, чем в грунте. Маки можно пересаживать; размножают семенами.
Наиболее распростаренные виды маков: мак полевой мак голубой мак голостебельный (сибирский) мак восточный и прицветковыйМак полевой (самосейка) – растение однолетнее. За блестящие лепестки его называют также “шелковым маком”. Цветет с конца мая до осени.
Семена очень мелкие, поэтому их лучше предварительно намочить и смешать с песком в соотношении 1:10. Сажать гнездовым всходы прореживать. Чтобы продлить сроки цветения, можно сеять несколько раз в течение сезона с интервалами 20–30 дней.
Мак голубой – двулетнее растение, можно использовать как однолетник. Семена высевают в грунт весной, всходы прореживают.
Мак голостебельный, или сибирский – многолетнее растение, используется и как двулетник. Цветет с мая по сентябрь. Семена высаживают весной или в августе. При подзимнем посеве зацветает в мае следующего года.
Маки восточный и прицветковый – многолетние неприхотливые морозостойкие растения. Хорошо растут на открытом месте, легко переносят небольшое затемнение, но при переувлажнении могут загнивать корни.
Оба вида размножаются семенами, корневыми и зелеными черенками. Посев производят рано весной в парники или теплицы, пикируют в фазе 1–2-х настоящих листьев и сразу высаживают на постоянное место. На черенки используют боковые слабые побеги, которые осторожно срезают и высаживают на затененные, влажные гряды. Лучшее время пересадки – середина лета или 2-я половина августа.