В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
aliina000
aliina000
11.02.2020 13:50 •  Информатика

Составьте программу, сортирующую нечетные элементы целочисленного массива по возрастанию методом выбора.​

Показать ответ
Ответ:
irinatsotok7
irinatsotok7
09.02.2020 20:31

В программе MS Word создайте новый документ. Файл сохраните в папке класса с именем Фамилия.docx.

В созданный документ вставьте скриншот рабочего стола, в случае необходимости измените размер изображения, на вкладке Формат в группе Размер..

На вкладке Формат в группе Упорядочить выберите Обтекание текстом - Вокруг рамки , затем расположите рисунок в центре листа.

На вкладке Вставка в группе Иллюстрации выберите подходящие Фигуры и подпишите основные элементы Рабочего стола.

Объяснение:

доступно ? Это просто действия с компьютером и программой Microsoft Word. Единственное, что тут можно не знать, это как делать скриншот, и это кнопка 'Print screen'(на клавиатуре)

0,0(0 оценок)
Ответ:
osumika
osumika
28.12.2021 05:17
Народ последнюю задачку проверьте опять не могу найти ошибку
УСЛОВИЕ:
Дано натуральное четырехзначное число. Найти наименьшую нечетную цифру в числовой записи данного числа.
Формат входных данных
Входной файл содержит натуральное четырехзначное число.
Формат выходных данных
Выведите наименьшую нечетную цифру в числовой записи данного числа. Если нечетных цифр в числе нет, выведите в выходной файл -1.

РЕШЕНИЕ:
PascalВыделить код1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 var n,a,b,c,d:integer; f,g:text; begin assign(f,'input.txt'); assign(g,'output.txt'); reset(f); rewrite(g); readln(f,n); a:=n div 1000; b:=n div 100 mod 10; c:=(n mod 100) div 10; d:=n mod 10; if (a mod 2=0) and (b mod 2=0) and (c mod 2=0) and (d mod 2=0) and (n<>0)  then writeln(g,'-1') else if (a<=b) and (a<=c) and (a<=d) then writeln(g,a) else if (b<=a) and (b<=c) and (b<=d)then  writeln(g,b) else if (c<=a) and (c<=b) and (c<=d) then writeln(g,c) else if (d<=a) and (d<=b) and (d<=c) then writeln(g,d) else close(f); close(g); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота