В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
asdfgh21
asdfgh21
23.01.2023 13:07 •  Информатика

Составьте программу табулирования функции y(x), выведите на экран значения x и y(x). программирование на С#


Составьте программу табулирования функции y(x), выведите на экран значения x и y(x). программировани

Показать ответ
Ответ:
настюшанастя1200
настюшанастя1200
06.03.2020 07:44
//1.
const god1=1626;
      god2=2015;            bank=0.07;      var
summa:real;
begin
summa:=24;
for var  i:=god1 to god2 do
summa:=summa+(summa*bank);
writeln(summa);
end.
//2.
var
a,b:integer; 
begin
read(a);
b:=0;
for var i:=1 to length(inttostr(a))  do begin
b:=b*10+a mod 10; a:=a div 10;
end;
writeln(b);
end.
//3.
const s=0.05;
var 
d:integer;
z:real;
begin
read(z);
d:=0;
repeat
inc(d);
z:=z-z*s;
until z<=30;
writeln(d);
end.
//4.
var
b,c:integer;
a:real;
begin
writeln('Кол-во $ и какой проц. годовых?');
readln(a,b);
c:=0;
while a<1000000 do begin
a:=a+a*(b/100);
inc(c);
end;
writeln(c);
end.
//5.
const max=100;var
a,b,c,d:integer;
begin
b:=0;
writeln('Кол-во машин?');
read(d);
writeln('Перечислите вес груза');
read(a);
c:=a;
for var i:=1  to d-1 do begin
read(a);
while c<=max do begin
inc(b);
c:=c+a;
end;
end;
writeln(b);
end.
//ABC Pascal
0,0(0 оценок)
Ответ:
alina1abikeeva
alina1abikeeva
21.11.2022 18:55
Задача 1.
const
  n=30;
var
  a,b:array[1..n] of integer;
  i,j,k:integer;
begin
  { самое сложное - создать такой массив,
    где положительные и отрицательные элементы будут случайно
    перемешаны и их будет по n/2.
    Если организовать ввод с клавиатуры, то это гораздо проще.
  }
  Randomize;
  { инициализация "флажком" - значением 1000 }
  for i:=1 to n do a[i]:=1000;
  { сначала генерируем n/2 случайных отрицательных на случайных местах }
  for i:=1 to (n div 2) do
  begin
    k:=Random(50)-50; { случайное отрицательное значение }
    { а теперь ищем случайное свободное место }
    repeat
      j:=Random(30)+1
    until a[j]=1000;
    a[j]:=k
  end;
  { теперь осталось сгенерировать n/2 случайных положительных чисел
    и разместить их на свободных местах }
  for i:=1 to (n div 2) do
  begin
    k:=Random(50)+1; { случайное положительное значение }
    { а теперь ищем свободное место }
    j:=0;
    repeat
      Inc(j)
    until a[j]=1000;
    a[j]:=k
  end;
  { и только отсюда начинается собственно задание }
  Writeln('Исходный массив');
  for i:=1 to n do Write(a[i]:4);
  Writeln;
  { j - количество обработанных отрицательных,
    k - количество положительных,
    а массив строим так, что отрицательные элементы на нечетных местах }
  if a[1]<0 then begin b[1]:=a[1]; j:=1; k:=0 end
  else begin b[2]:=a[1]; j:=0; k:=1 end;
  for i:=2 to n do
    if a[i]<0 then
    begin Inc(j); b[2*j-1]:=a[i] end
    else begin Inc(k); b[2*k]:=a[i] end;
  Writeln('Результирующий массив');
  for i:=1 to n do Write(b[i]:4);
  Writeln
end.

Тестовое решение:
Исходный массив
  43  44  34  21  14 -26  32  35 -25  -8  42 -35 -37  12  45 -25  31   8 -16  -5   8 -25 -19 -15 -27 -16  12  26 -14 -41
Результирующий массив
 -26  43 -25  44  -8  34 -35  21 -37  14 -25  32 -16  35  -5  42 -25  12 -19  45 -15  31 -27   8 -16   8 -14  12 -41  26
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота