Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Сельга7
30.09.2020 15:02 •
Информатика
Составьте программу ,увеличивающую четные элементы линейного массива a[1..n] на 1
Показать ответ
Ответ:
pantehnik77777oz07f1
27.09.2020 18:57
Var
i,n:integer;
a:array [1..1000] of integer;
Begin
Read(n);
For i:=1 to n do
Read(a[i]); //вводим элементы массива
For i:=1 to n do begin
If a[i] mod 2 = 0 then inc(a[i]); //прибавляем 1 к четным элементам
Write(a[i], ' ');
End;
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
vladamalaxova
29.05.2021 15:15
Надо создать программу Php для решение этой задачи КОЭФФИЦИЕНТ ЧИСТАЯ СТОИМОСТЬ =ВЫПЛАТЫ В МЕСЯЦ* СРОК = (1+ %)^ СРОК * ЧИСТАЯ СТОИМОСТЬ ЧИСТАЯ СТОИМОСТЬ = (ВЫПЛАТЫ В МЕСЯЦ* СРОК)/...
73Женя91
18.03.2022 02:21
Вшкольной библиотеке находится 16 стеллажей с книгами на каждом стеллаже 8 полок библиотекарь сообщил пете что нужная ему книга находится на пятом стеллаже на третьей сверху полке...
pait
19.07.2021 06:22
Сколько символов содержит сообщение, записанное с 256-символьного алфавита, если его объем составил 1/16 часть мегабайта?...
anastasiatroegu
19.07.2021 06:22
Составьте программу в pascal abc которая определяет является ли число 10 двузначным....
leha2018
19.07.2021 06:22
Переведите в восьмеричную систему счисления 152+2,35...
Никитаотличник1
04.02.2022 07:38
Составь список объектов, по алфавиту: 1. список учебников в твоем портфеле. 2. список знакомых частей речи. 3.список действий....
Нармин59
04.02.2022 07:38
Какова роль процессора? чем характеризуется производительность процессора?...
БолатовДосжан
04.02.2022 07:38
Сколько нулей в двоичной записи числа 222 в 10 степени...
Alikhan666
28.08.2022 14:40
Как создать информационную модель цветка...
максимилиан123098
19.01.2021 19:35
Как на компьютере с windows 10, подключиться к wi-fi, если значка wi-fi нет на рабочем...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i,n:integer;
a:array [1..1000] of integer;
Begin
Read(n);
For i:=1 to n do
Read(a[i]); //вводим элементы массива
For i:=1 to n do begin
If a[i] mod 2 = 0 then inc(a[i]); //прибавляем 1 к четным элементам
Write(a[i], ' ');
End;
End.