В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tihon123123
tihon123123
31.05.2021 09:46 •  Информатика

Составьте программу, в которой у пользователя запрашивают шестизначное число, а затем выводят в строчку через промежутки по порядку его цифру.

Показать ответ
Ответ:
vlad041204
vlad041204
23.06.2020 10:59

Один из примеров реализации на JS, Pascal:


Составьте программу, в которой у пользователя запрашивают шестизначное число, а затем выводят в стро
Составьте программу, в которой у пользователя запрашивают шестизначное число, а затем выводят в стро
0,0(0 оценок)
Ответ:
sadyk771
sadyk771
23.06.2020 10:59

program raf105;

var

 a:array[1..6] of integer;

 n,i: integer;

begin

 write('Введите шестизначное число: ');

 readln(n);

 a[1]:= n div 100000;

 a[2]:= (n div 10000) mod 10;

 a[3]:= (n div 1000) mod 10;

 a[4]:= (n div 100) mod 10;

 a[5]:= (n div 10) mod 10;

 a[6]:= n mod 10;

 write('Вывод: ');

 for i:= 1 to 6 do

   write(a[i],' ');

 end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота