В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dvoeshnik101
dvoeshnik101
28.09.2020 11:16 •  Информатика

Составьте программу в pascal: компьютер задаёт случайное двухзначное число х, например 39; компьютер задаёт случайное однозначное число у, например 8; необходимо получить новое трехзначное число z, а именно 389т.е.число у вписать в середину х​

Показать ответ
Ответ:
natalicharry
natalicharry
29.05.2020 09:09

var x,y,z:integer;

begin

   randomize;

   x:=1;

   repeat x:=random(100) until x>9;

   y:=random(10);

   z:=(x div 10)*100+y*10+(x mod 10);

   writeln('x=', x);

   writeln('y=', y);

   writeln('z=', z);

end.

0,0(0 оценок)
Ответ:
Барвлвовь
Барвлвовь
29.05.2020 09:09

program raf105;

var x,y,z:integer;

begin

x:=random(10,99);

writeln('Компьютер выбрал число ',x);

y:=random(1,9);

writeln('Компьютер выбрал число ',y);

z:= x mod 10;

x:= (x-z)*10;

z:= (x+z)+y*10;

writeln('Компьютер переместил второе число в середину первого. Результат: ',z);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота