В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ksyunik435
ksyunik435
06.05.2020 23:08 •  Информатика

Составьте программу в PascalABC, которая печатает в первой строке два знака '& &' через один пробел, во второй – через два пробела '& &', в третьей - '& &' через три пробела, ..., в строке с номером 9 - & (через 9 пробелов) & .

Печать строки оформить через процедуру. Число строк вводить с клавиатуры.

Показать ответ
Ответ:

// PascalABC.NET

procedure MadPrt(n: integer) := Writeln('&' + n * ' ' + '&');

begin

 var n := ReadInteger('Сколько нужно строк?');

 for var i := 1 to n do

   MadPrt(i)

end.


Составьте программу в PascalABC, которая печатает в первой строке два знака '& &' через один
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота