В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу в паскаль для вычисления: найти радиус окружности, описанной около правильного n-угольника со стороной а

Показать ответ
Ответ:
даня1166
даня1166
10.10.2020 00:56

var

   n : integer; // количество сторон (углов)

   a : integer; // длина стороны

   

begin

   write('введите количество сторон n= ');

   readln(n);

   write('введите длину стороны a= ');

   readln(a);

   writeln('радиус описанной окружности R=', a/2*(sin(pi/n)));

end.

не забываем что паскаль считает в радианах и формула расчета соответственная...

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота