В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
virudskaya
virudskaya
17.08.2020 18:54 •  Информатика

Составьте программу в паскаль, которая запрашивает ввод целых положительных чисел и определяет произведение нечётных из них. признаком конца ввода считать ввод числа -4.

Показать ответ
Ответ:
PrOFy100
PrOFy100
21.07.2020 20:48
Var a:array[1..1024] of integer;
p:longint;
i:integer;
begin
p:=1;
repeat
i:=i+1;
readln(a[i]);
if a[i]<0 then begin if a[i]<>-4 then writeln('Vvedite polozhitelnoe chuslo');
end
else
begin
if a[i] mod 2<>0 then p:=p*a[i];end;
until a[i]=-4;
writeln('Proizvidenie = ',p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота