В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Roman310399
Roman310399
07.07.2020 13:07 •  Информатика

составте программу в паскаль. приписать по 1 в начало и в конец записи числа n (было n=3456, стало n=134561). 2) найти все двузначные числа, которые числа которые делятся на m или содержат цифру m. 3) составить программу, которая прибавляет ко всем элементам массива по единице ,если массив заполняется с клавиатуры.

Показать ответ
Ответ:
bossobychnyy
bossobychnyy
21.07.2020 17:29
1)
var a:integer;
begin
writeln('введите число');
readln(a);
writeln('1',a,'1');
end.
2)
var a,b,c:integer;
begin
writeln('введите число');
readln(a);
for c:=10 to 99 do
begin
if (c mod a = 0)  or (a = c mod 10) or (a = c div 10) then
writeln(c);
end;
end.
3) 
var b,c:integer;
a:array [1..100] of integer;
beginwriteln('введите длину массива');
readln(b);
for c:=1 to b do
begin
writeln('введите элемент массива');
readln(a[c]);
a[c]:=a[c]+1;
writeln(a[c]);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота