Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Smash2302
14.04.2023 22:33 •
Информатика
Составьте программу в паскаль с while. у малыша к банок варенья. в первый день карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. через сколько дней варенье кончится?
Показать ответ
Ответ:
Kseniya000001
30.08.2020 19:23
Var K, den, s_el: real;
Begin
Writeln('Введите K банок');
readln(K);
s_el:=1;
K:=K - s_el;
den:=1;
While (K>0) do
Begin
s_el:= s_el * 1.5;
K:=K - s_el;
den:=den+1;
end;
Writeln('Варенье кончится через ', den, ' дней');
readln();
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nagimako
23.09.2020 09:34
В системе счисления с каким основание не может быть записано число 371...
Demorage
09.05.2020 00:39
В таблице приведены за к поисковому серверу. Расположите обозначения за в порядке убывания количества страниц, которые найдет поисковый сервер по каждому за Для...
Dyba
03.02.2020 02:33
Сколько записей в данном фрагменте удовлетворяют условию: (Часть света = «Америка») ИЛИ НЕ (Население 31,9)?...
зулейха4
21.05.2022 11:27
Информатика даны два целых числа . найти их среднее арифмитическое и средние...
еваСИЛ
21.05.2022 11:27
Напишите вычисление суммы двух положительных чисел...
fox02713foxsi
14.10.2022 02:10
Информатика 8 класс . Смотреть на скрин....
Крекир
16.09.2021 13:11
Информатика,7 класс у меня контрольная По длинам трех отрезков, введенных пользователем, определить возможность существования треугольника, составленного из этих...
998l
02.03.2020 23:20
Информатика 8 класс . Смотреть на скрин....
dmahov228
30.08.2020 03:21
Запишите для робота два различных алгоритма решения задачи, представленной на рисунке. какой из этих алгоритмов лучше? почему?...
bulyginanastya
13.05.2023 10:48
НАЧАТЬ ответь на 5 во из предмета Математика за 48 ч.: +50 б. 0/5 2д : 00ч НАЧАТЬ ответь на 10 во из предмета Математика за 48 ч.: +100 б. 0/10 2д : 00ч НАЧАТЬ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Begin
Writeln('Введите K банок');
readln(K);
s_el:=1;
K:=K - s_el;
den:=1;
While (K>0) do
Begin
s_el:= s_el * 1.5;
K:=K - s_el;
den:=den+1;
end;
Writeln('Варенье кончится через ', den, ' дней');
readln();
end.