В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
AknelaYouTuber
AknelaYouTuber
17.04.2022 15:53 •  Информатика

Составьте программу в паскале для поиска: a)суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов

Показать ответ
Ответ:
mmmmmvbbbbb
mmmmmvbbbbb
07.10.2020 22:05
А) uses crt;
const n=10;
var a:array[1..n] of integer;   
i,sum:integer;
begin
for i:=1 to n do   
begin         
a[i]:=random(100)-50;         
write(a[i]:4);         
if a[i]>0 then sum:=sum+a[i];   
end;
writeln;
writeln('Сумма положительных элементов = ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота