В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
localhend
localhend
18.04.2020 20:31 •  Информатика

Составьте программу в паскале, которая находит наименьшее из чисел кратное 3.количество чисел не меньше 1000.

Показать ответ
Ответ:
sandershvnz
sandershvnz
27.05.2020 15:41

const

  inf = 32767;

var

  a, min : integer;

begin

  min := inf;

  while not eoln do

  begin

    read (a);

    if (a < min) and (a mod 3 = 0) then min := a;

  end;

  if min < inf then writeln (min)

  else writeln ('Нет чисел, кратных 3-ем');

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота