В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
giulia250305
giulia250305
08.06.2022 05:27 •  Информатика

Составьте программу в паскале выводящую значение true\false №9 данное четырехзначн. число читается одинаково справа налево и слева на право и №11 сумма каких-либо 2 цифр заданного натурального трехзначного числа n равна третьей цифре

Показать ответ
Ответ:
камран12
камран12
12.07.2020 01:23
№9

var n: integer;
begin
     readln(n);
     if (n mod 10 = n div 1000) and (n div 10 mod 10 = n div 100 mod 10) then
        writeln('TRUE')
     else
         writeln('FALSE');
end.

№11

var n, a, b, c: integer;
begin
     readln(n);
     c := n mod 10; {Третья цифра}
     b := n div 10 mod 10; {Вторая цифра}
     a := n div 100; {Первая цифра}
     if (a + b = c) or (a + c = b) or (b + c = a) then
        writeln('TRUE')
     else
         writeln('FALSE');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота