В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Lanevskie2004
Lanevskie2004
15.04.2023 10:08 •  Информатика

составьте программу вычисления.

Из первой задачи 9 вариант и из второй 9 вариант


составьте программу вычисления. Из первой задачи 9 вариант и из второй 9 вариант

Показать ответ
Ответ:
AlinaCocky
AlinaCocky
15.03.2023 20:21
Var 
a: array[1..100] of integer; 
n, i: byte; 
sum, p: integer;
begin 
writeln('1. Случайным образом'); 
Randomize; 
write('Введите размер массива: '); 
readln(n); 
sum:=0; p:=1; 
for i:=1 to n do   
begin     
a[i]:=Random(101)-50;     
write(a[i]:4);     
sum:=sum+a[i];     
p:=p*a[i];   
end; 
writeln; 
writeln('Сумма = ', sum:5); 
writeln('Произведение = ', p:5); 
sum:=0; p:=1; 
writeln(''); 
writeln('2. С клавиатуры'); 
for i:=1 to n do   
begin   
write('Элемент ', i, ' = ');   
readln(a[i]);   
sum:=sum+a[i];   
p:=p*a[i];   
end; 
writeln('Сумма = ', sum:5); 
writeln('Произведение = ', p:5);
end.
0,0(0 оценок)
Ответ:
AlinaAlina707
AlinaAlina707
05.08.2020 21:48
Одно из трех:
1) Задача проще чем кажется, поэтому не нужно ничего усложнять. Достаточно просто все записать в соответствии в таблицу и отсортировать по столбцу "Скорость" при фильтров. Что я и сделал (см. файл Excel лист "Предтеч просто")
2) В задаче НЕ достаточно условий, т.к. мне стало не ясно зачем тут 4-ре исследователя!? Я пытался их приплести к условию задачи (Лист: "Предтеч - сложно"), Но мне кажется получился бред.
3) Возможно я чего-то не понял из всего информационного хаоса царившего в данной задаче, но как решать её по другому я не знаю.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота