В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составьте программу вычисления куба суммы всех четных чисел от 2 до 100 и как она работает

Показать ответ
Ответ:
2ewgv423t
2ewgv423t
21.08.2020 21:46
program task31102063; var  Sum: real; begin  for var i := 2 to 100 do    if i mod 2 = 0 then      Sum := Sum + Power(i, 3);  Writeln(Sum); end.

Принцип очень прост: инициализируем цикл с итератором, равным 2, до 100. Далее проверяем, является ли итератор (то есть число) чётным - для этого просто возьмем целую часть от деления на 2. Если равна нулю, то число чётное, если нет - то это остаток.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота