Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
namazovaainur
10.02.2022 18:09 •
Информатика
Составьте программу вычисления площади треугольникк с основанием a и b и высотой h. значение a и h введите с клавиатуры.
Показать ответ
Ответ:
sergei66284
01.10.2020 23:42
Program treugolnik;
Uses crt;
var a,h,s: real;
Begin clrscr;
write('Основание a = ');
readln(a);
write('Высота h = ');
readln(h);
writeln;
if (a<=0) or (h<=0) then
writeln('Значения не могут быть отрицательными или равняться нулю')
else
begin
s:=(1/2)*a*h;
writeln('Площадь треугольника s = ',s);
end;
readln;
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
шахид2
10.10.2021 12:38
Рассчитайте объём видеопамяти, необходимой для хранения графического изображения, занимающего весь экран монитора с разрешением 1024 x 768 и количеством отображаемых цветов,...
лана278
10.10.2021 12:38
Решить pascal. только не с интернета, они там не правильные. 1. дано целое число n и набор из n вещественных чисел. вывести сумму и произведение чисел из данного набора 2.дано...
anastasiyaroma11
28.01.2021 14:34
1. сколько ячеек в диапазоне b5: d9? 2. чтобы переместиться на одну ячейку вниз нужно нажать: а) tab б) enter в) клавиша стрелка вниз г) мышью 3. строки в рабочей книге обозначаются:...
Lambik290
14.01.2023 06:17
Определи и запиши результат выполнения программы при х=10 и к=7 (Python) !...
mila336
14.01.2023 06:17
Напишите, в каких областях используются и применяются роботы: [ 2 ] 1. 2.3.4.5....
Alinalina080206
23.06.2022 08:06
Сопоставьте функции с его выполняемыми действиями 1)str(A) 2)int(A) 3)len(A) A. преобразует строку A в число B. определяет количество символов в заданном строке А С. преобразует...
DemonOfFood
22.07.2020 03:06
Сколько ячеек оперативной памяти нужно для записи слова стол...
anastasiya249
16.02.2021 16:53
Внекоторых языках программирования (например языке питон )переменные не нужно объявлять.обсудите в классе какие достоинства и недостатки имеет такой подход...
katsden
16.02.2021 16:53
Составьте решение на алго- метрическом языке и блок-схему вычисления значения функции: у=5х+4,если х или =2; 1/х,если х 2....
azat20142014
16.02.2021 16:53
Написать программу, в которой для массива из 20 элементов, заполненного случайными числами от -20 до +20, 20 раз выполняется следующая процедура: слева направо по порядку сравниваются...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Uses crt;
var a,h,s: real;
Begin clrscr;
write('Основание a = ');
readln(a);
write('Высота h = ');
readln(h);
writeln;
if (a<=0) or (h<=0) then
writeln('Значения не могут быть отрицательными или равняться нулю')
else
begin
s:=(1/2)*a*h;
writeln('Площадь треугольника s = ',s);
end;
readln;
End.