Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
nastasttv00
19.12.2020 23:12 •
Информатика
Составьте программу вычисления степени числа а с натуральным показателем n. (записать варианты программы с разными циклов while, repeat, for).
Показать ответ
Ответ:
кирюха6677
30.08.2020 18:28
FOR
Var a, i, n, sum: integer;
Degin
ReadLn(a, n);
Sum := 1;
For i := 1 to n do sum := sum * a;
WriteLn(sum);
End.
WHILE
Var a, i, n, sum: integer;
Begin
Read(a, n);
Sum := 1;
While i <> n do
Begin
Sum := sum * a;
Inc(i);
End;
Writeln(sum);
End.
REPEAT
Var a, i, n, sum: integer;
Begin
Read(a, n);
Sum := 1;
If n <> 0 then
Repeat
Begin
Sum := sum * a;
Inc(i);
End;
Until i = n;
WriteLn(sum);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
танюша108
07.01.2023 07:45
3с циклических алгоритмов для а в с паскаль...
mashacat763p01bj9
04.09.2022 10:29
Найдите среднюю скорость движения мотоциклиста если он на путь длиной 84 км проехал со скоростью 42 км ч 76 км со скоростью 38 км ч...
дашуля298
01.09.2021 17:06
Решить по криптографии. 3й номер нужен. заранее...
zena30331
12.10.2021 16:26
Составьте алгоритмы чертёжником,после исполнения которых будут получены следующий рисунок...
Амира573
27.01.2022 16:53
Рассмотрите скритшоты программного кола для проверки арифметическпрограмма выводит ошибку при запуске.код програмаа) определите ошибку в коде.b) предложите устранения ошибки информатика...
Саша5841
13.11.2022 08:58
Программа кумир. составить ❤нужно бегемота сделать...
Kristia03
04.03.2023 03:55
Укажите, к какому информационному процессу относится просмотр справочной 1)обработка 2)представление 3)передача 4)хранение 5)сбор...
VladIslaV231678
19.08.2022 12:44
Выбирите из списка файл с текстовой информацией 1)proba.ppt 2)proba.bmp 3)proba.doc 4)proba.avi...
sonyabush12345
19.08.2022 12:44
Расставь даты 40 -е гг. 19 в. в сша начала функционировать первая в мире компьютерная сеть. 1876 г. в россии построена телеграфная первая линия. 1895 г. в америке изобретён телифон....
evagir
08.03.2021 13:18
Составьте программу для вычисления y=tgx+x²+|z|...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Var a, i, n, sum: integer;
Degin
ReadLn(a, n);
Sum := 1;
For i := 1 to n do sum := sum * a;
WriteLn(sum);
End.
WHILE
Var a, i, n, sum: integer;
Begin
Read(a, n);
Sum := 1;
While i <> n do
Begin
Sum := sum * a;
Inc(i);
End;
Writeln(sum);
End.
REPEAT
Var a, i, n, sum: integer;
Begin
Read(a, n);
Sum := 1;
If n <> 0 then
Repeat
Begin
Sum := sum * a;
Inc(i);
End;
Until i = n;
WriteLn(sum);
End.