Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
viktoriasmirnova200
09.12.2021 02:22 •
Информатика
"составьте программу вычисления суммы элементов от первого отрицательного и до конца" (pascal abc)
Показать ответ
Ответ:
VASILIEVAALEXANDRA
03.07.2020 13:24
Var
mas:array[1..100] of integer;
i,n,sum:integer;
bool:boolean;
begin
bool:=false;
sum:=0;
readln(n);
for i:=1 to n do
begin
read(mas[i]);
if mas[i]<0 then
bool:=true;
if bool=true then
sum:=sum+mas[i];
end;
writeln(sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Срочноооооопжлст
13.03.2023 18:03
Вэлектронной таблице значение формулы=сумм(b1: b4) равно 25,а значение формулы =сумм(b4: b6) равно 17. чему равно значение ячейки =срзнач(b1: b6) равно 6...
arkadyhmp074l6
10.04.2020 00:07
Составьте и запишите компьютерную программу на языке программирования паскаль для решения следующей : найти наибольший общий делитель (сокращённо нод) двух целых чисел х и y. кроме...
dashabar1208
21.04.2022 13:52
Надо определить закономерность и вместо точек вставить нужные числа и символы.15 б...
Анюта3Б
05.12.2020 17:14
Таблица стоимости перевозок устроена следующим образом: числа, стоящие на пересечениях строк и столбцов таблиц, означают стоимость проезда между соответствующими соседними станциями....
egor2002browhnq9
03.03.2023 01:02
Один вопрос! ! только точный ответ! к числовой информации относятся сведения, представленные: только цифрами цифрами и знаками препинания цифрами и знаками арифметических операций...
anastasyaantonova07
07.11.2022 13:30
1. в некоторых операционных системах имя файла может включать до а) 200 символов б) 235 символов в) 255 символов г) 300 символов 2. определите тип файла с расширением doc. а) звуковой...
DimaLeonov2000
20.05.2022 00:46
№1 дано четырехзначное число. проверить, является ли оно палиндромом. примечание: палиндромом называется число, слово или текст, которые одинакового читаются слева направо и справа...
tatyankasas
23.05.2023 02:17
Скласти допомiжний алгоритм переïзду перехрестя ....
Маджидия
08.06.2022 13:50
Вкодировке кои-8 каждый символ кодируется одним байтом.определите информационный объем из 35 символов в этой кодировке....
Cherep666
25.12.2021 09:30
На python 1.даны положительные числа a и b (a b). на отрезке длины a размещено максимально возможное количество отрезков длины b (без наложений). не используя операции умножения...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
mas:array[1..100] of integer;
i,n,sum:integer;
bool:boolean;
begin
bool:=false;
sum:=0;
readln(n);
for i:=1 to n do
begin
read(mas[i]);
if mas[i]<0 then
bool:=true;
if bool=true then
sum:=sum+mas[i];
end;
writeln(sum);
end.