В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Юлия45684
Юлия45684
10.06.2021 10:21 •  Информатика

Составьте программу вычисления суммы всех двузначных чисел, имеющих в своем составе цифру 1 или 3. ( программа для паскаля, 9 класс и function не проходили, поэтому как можно проще и я так думаю с var или тому подобное) нужно

Показать ответ
Ответ:
Kirikplay11
Kirikplay11
20.07.2020 14:30
Var s,i:integer;
begin
s:=0;
for i:=10 to 93 do
begin
if (i mod 10 = 1) or (i div 10 = 1) or (i mod 10 = 3) or (i div 10 = 3) then
s:=s+i;
end;
writeln('Сумма всех двузначных чисел, имеющих в составе 3 или 1 равна ', s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота