В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Finnwolfhardd
Finnwolfhardd
01.07.2022 02:57 •  Информатика

Составьте программу вычисления у по заданному х. y=-3х, х <0 х+5, x20
Пример входных данных
x=-5
X=2​


Составьте программу вычисления у по заданному х. y=-3х, х <0 х+5, x20 Пример входных данныхx=-5X

Показать ответ
Ответ:
Murua
Murua
16.02.2021 22:36
Var
    a, b: integer;

function greatest_common_divisor(m, n: integer): integer;
var
    modulo: integer;
begin
    modulo := m mod n;
    if modulo = 0 then
        greatest_common_divisor := n
    else
        greatest_common_divisor := greatest_common_divisor(n, modulo)
end;

procedure reduce_the_fraction(a, b: integer);
var
    gcd: integer;
    sign: string;
begin
    gcd := greatest_common_divisor(a, b);
    if a * b < 0 then
        sign := '-';
    writeln(sign, abs(a) / gcd, '/', abs(b) / gcd);
end;

begin
    write('Enter two numbers: ');
    readln(a, b);
    reduce_the_fraction(a, b);
end.
0,0(0 оценок)
Ответ:
gre4g3g4
gre4g3g4
04.09.2022 02:17

Если это вопрос то тогда да.

Текстовые и графические алгоритмы, линейный алгоритм ( такие бывают )

Алгоритм (модель процесса решения задачи) может быть представлен в виде текста на естественном языке или графически (блок-схемой).

Алгоритм на естественном языке даёт человеку более подробную информацию, а блок схема – это наглядный представления информации. Алгоритм можно разделить по записи (форме представления) на текстовые (описание на естественном языке) и графические (блок-схемы). Алгоритм на естественном языке даёт более подробную информацию, а блок-схема – более наглядную.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота