В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tiamaressp035gw
tiamaressp035gw
26.06.2021 05:45 •  Информатика

Составьте программу вычисления выражения (разными применяя каждый из операторов while,repeat,for) a^p, где p - целое число. pascal / надо.

Показать ответ
Ответ:
Lerakadyrova
Lerakadyrova
04.08.2020 10:00
1)Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1; i:=0;
  while i<p do
  begin
    c:=c * a;
    inc(i);
  end;
  writeln(c);
  readln;
end.

2) Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1; i:=0;
  repeat
    c:=c * a;
    inc(i);
  until i=p;
  writeln(c);
  readln;
end.

3) Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1;
  for i:=1 to p do
    c:=c * a;
  writeln(c);
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота