В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
golubevaleshka
golubevaleshka
23.05.2022 22:22 •  Информатика

Составьте программу вычисления значений функции f(x) на отрезке [a,b] с шагом h. результат представьте в виде таблицы, первый столбец которой включает в себя значения аргумента, второй – соответствующие значения функции f(x)=sin x+0,5 cos x.

Показать ответ
Ответ:
Kepka229
Kepka229
07.10.2020 14:09
//Pascal
var
  a, b, h, x, y: real;
begin
  write('Введите a и b = ');
  readln(a, b);
  write('h(шаг) = ');
  readln(h);
  writeln('x':5,'y':10);
  x := a;
  while x <= b do
  begin
    y := sin(x)+0.5*cos(x);
    writeln(x:7:2, y:10:3);
    x := x + h;
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота