В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sofom132
sofom132
07.10.2022 03:21 •  Информатика

Составьте программу, вычисляющую количество цифр введенного натурального числа
Pascal ABC

Показать ответ
Ответ:
мвдии
мвдии
08.09.2021 22:20

var n, counter : integer;

begin

counter := 0;

writeln('Введите число: ');

readln(n);

while n > 0 do

begin

counter := counter + 1;

n := n div 10;

end;

writeln('Количество цифр в данном числе: ', counter);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота