В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Siiii
Siiii
03.09.2021 02:18 •  Информатика

Составьте программу вычисляющую площадь круга (S) и длину окружности (1) радиус который равен R. Радиус круга вводится пользователем (PI=3,14)

Показать ответ
Ответ:
MrDackes
MrDackes
01.04.2023 13:30

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

ld func1(ld x, ld y, ld z){

   return 5 * atan(x) - (1/4) * acos(x) * ((x + 3 * abs(x-y) + pow(x,2))/(abs(x-y) * z + pow(x,2)));

}

ld func2(ld x, ld y, ld z){

   return (pow(M_E,abs(x-y)) * pow(abs(x-y),x+y))/(atan(x)+atan(z)) + pow(pow(x,6) + pow(log(y),2),(1/3));

}

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   ld x,y,z;

   cin >> x >> y >> z;

   cout << func1(x,y,z) << "\n" << func2(x,y,z);

}

P.S если я где-то косякнул по невнимательности, то пишите, исправим

0,0(0 оценок)
Ответ:
valentingordien
valentingordien
01.04.2023 13:30
Вывести числа от 1 до 20 и от 20 до 40 так же, просто цифры поменяй.
var
i:integer;
begin
writeln('1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20');
readln
end.

Вывести квадраты чисел от 1 до 10
var   
i: integer;
begin    
for i:=1 to 10 do      
writeln(i:4,'   ',sqr(i):4);    
readln
end.

Число n вводят с клавиатуры.Напечатать n раз число 5 (и оставшиеся 2 задачи можно этой же, просто поменяй кое-какие детали, подумай какие)
var
i,n:integer;
begin
writeln('Введите кол-во повторов числа: ');
readln(n);
for i:=1 to n do
writeln('5');
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота