Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
LinaPozniak08
11.09.2021 16:41 •
Информатика
Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль
Показать ответ
Ответ:
vamagic2001
04.10.2020 17:12
Var s:string;
begin
for var i:=1000 to 9999 do
begin
s:=i.ToString;
if((strtoint(s[1])+strtoint(s[2])+strtoint(s[3])+strtoint(s[4]))<4)then write(i,' ');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Valeria25092006
27.01.2020 07:32
ответьте на вопросы: 1.Для чего нужно добавлять оглавление в документы? 2.Для чего необходимо обновлять оглавление...
89533807722qoznnn7
02.10.2022 01:33
Впервый час работница делает 12 заготовок во второй на 2 заготовки больше и т.д.сколько заготовок она сделает за 8 часов работы. написать в виде программы паскаль авс...
maliiii02
26.05.2021 16:05
НУ У МЕНЯ НЕТУ Я НЕ МОГУ МНОГО ПОСТАВИТЬ МНЕ СОР НАДО ПИСАТЬ...
Max325t
13.07.2021 08:58
Логомиры. как нарисовать:1. Четыре квадрата подряд.2. Четыре круга подряд.3. Четыре треугольника подряд.4. Четыре узора подряд....
лиза2699
22.03.2020 01:12
найти сумму элементов массива кратное 7 на Паскале...
mo14yn
13.07.2020 21:59
Які типи веб сторінок розріняють?Що спільного та які відмінності вони мають?...
198912
15.08.2022 22:54
1) сколько бит в 1 байте 2) сколько байт в 4 кб 3)сколько байт в 0,5 мб 4) сколько бит в 1 кб 5) написать в байтах: считая, что каждый символ закодирован двумя байтами, оценивает...
laravysotskaya
15.08.2022 22:54
Садовник вырастил 10 роз, расположив их в пять рядов, по четыре розы в каждом ряду. потом он решил вырастить двадцать пять кустов тюльпанов, расположив их в двенадцать рядов, по пять...
АлисияАлисия
14.05.2023 08:12
Найдите все пятизначные числа, которые при делении на 133 в остатке 125, а при делении на 134 в остатке 111. для питона...
angelina0512200
14.05.2023 08:12
Как можно оценить надежность информации,скопированной из интернета ?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
for var i:=1000 to 9999 do
begin
s:=i.ToString;
if((strtoint(s[1])+strtoint(s[2])+strtoint(s[3])+strtoint(s[4]))<4)then write(i,' ');
end;
end.