В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ZKRMT
ZKRMT
25.05.2023 10:08 •  Информатика

Составьте программу: задать массив из 10 чисел, заданных с генератора случайных чисел, найти в нем максимальный элемент (привести лишь функцию main)

Показать ответ
Ответ:
AntihypeSPB
AntihypeSPB
13.10.2020 20:43

signed main() {

   const ll n = 10;

   srand(time(NULL));

   ll a[n];

   ll mx = -LLONG_MAX;

   for(ll i = 0; i < n; i++){

       a[i] = rand() % 100;

       mx = max(mx,a[i]);

   }

   cout << mx;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота