В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
BOT1111111
BOT1111111
04.03.2022 19:20 •  Информатика

Составьте программу закрашивания клеток поля, отмеченных звездочкой. Начальное положение Робота
где-то в центре поля.

Показать ответ
Ответ:
Sulaiman00
Sulaiman00
31.08.2022 22:08
#include <iostream>
using namespace std;

int main() {
    int m;
    cout << "m = ", cin >> m, cout << "\n";
    int b[m];
    srand(time(NULL));
    cout<<"array:\n";
    for (int i=0; i<m; i++)
    {
      b[i]=rand() % 50;
      cout<<b[i]<<" ";
    }
    cout << "\n";
    for (int i=0; i<m; i++)
     if ((i+1)%2==0) b[i] *= 2;
     else b[i]=0;
    for (int i=0; i<m; i++) cout << b[i] << " ";
    cout << "\n";
    return 0;
}

Пример:
m = 10
array:
47 3 29 46 36 31 2 2 20 20
0 6 0 92 0 62 0 4 0 40
0,0(0 оценок)
Ответ:
АнгелінаL
АнгелінаL
21.06.2021 14:23
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

function NewMatrix(n:integer):array[,] of integer;
begin
  Result:=MatrRandom(n,n,-50,50);
  Result.Println(4); Writeln(4*n*'-')
end;

function KS(a:array[,] of integer):(integer,integer);
begin
  var (k,s,n):=(0,0,a.RowCount-1);
  for var i:=0 to n-1 do
    for var j:=i+1 to n do
      if a[i,j]<0 then (k,s):=(k+1,s+a[i,j]);
  Result:=(k,s)
end;

begin
  var d:=NewMatrix(8);
  var (l,c):=KS(d);
  var t:=NewMatrix(10);
  var (n,a):=KS(t);
  var q:=NewMatrix(7);
  var (m,b):=KS(q);
  Writeln($'l={l}, c={c}, n={n}, a={a}, m={m}, b={b}');
  var (lp,rp):=(c/n+b/l,a/m);
  Writeln($'c/n+b/l={lp}{lp=rp?'' = '':'' <> ''}{rp}');
end.

Пример
 -25  12  43  -8 -15  15 -30  23
   7  49  50   4  38 -37  46  44
  17  21 -37  20  13 -27 -19 -20
   0 -50 -12 -37  23 -33  16 -37
 -43  -6 -35  30  27  11  48  12
   3  15  -8 -25 -38 -47  23  34
 -49  23 -27 -27 -28 -13 -17 -49
 -20  13  42 -16 -24 -43 -50 -10
--------------------------------
 -17  36  -4  -6  48 -34 -33 -44  23   2
 -34  48  32 -45 -32  -3 -22   4 -39 -50
  44  -8  42  20 -39 -36  -1 -36  20  14
 -15  -5  15 -48  43 -24   7 -21  37  36
   5 -33   1  20 -30 -15 -31 -26  -5  -6
 -44  22  46 -50  -4  41  45  26 -17  33
  17 -47 -14 -42 -33  22 -17  30 -37  42
  40  49  18 -24  -5  27  42 -29   0  26
  46 -26  20 -25   7  13  -1  15   6 -48
 -18  31  46 -47 -32   2  31  -8   3  -1
----------------------------------------
 -48 -11 -39   3   5 -43 -46
  20   5  19  50  23 -24   7
  38  -7 -16 -39   2   4 -28
  19 -27 -39   9 -42 -47  15
 -43  43  47  -1  19 -50  24
   6 -38 -34  21   0   9  30
 -41  38 -48   9   5 -12 -35
----------------------------
l=10, c=-275, n=25, a=-654, m=10, b=-369
c/n+b/l=-47.9 <> -65.4

Решить уравнение c/n+b/l=a/m, где l,c – количество и сумма отрицательных элементов матрицы d(8,8) ,
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота