В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Lkjgcvb
Lkjgcvb
24.12.2021 15:55 •  Информатика

Составьте программу, заменяющую из двух данных чисел меньшее число модулем разности, а большее - модулем произведения этих чисел.

Показать ответ
Ответ:
pastoling
pastoling
11.06.2020 19:08
//Pascal ABC.NET 3.1 сборка 1256

Var
 a,b,c:integer;
begin
read(a,b);
if a<b then
 begin
  c:=a;
  a:=abs(a-b);
  b:=abs(c*b);
 end
 else
 begin
  c:=b;
  b:=abs(a-b);
  a:=abs(a*c);
 end;
writeln('a=',a);
write('b=',b);
end.

Пример ввода:
-3
4
Пример вывода:
a=7
b=12
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота