В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
piotrewch
piotrewch
09.12.2021 02:03 •  Информатика

Составьте программу, заменяющую меньшее из двух данных чисел суммой, а большее – произведением этих чисел. с оператора выбора- case

Показать ответ
Ответ:
AngelRush0
AngelRush0
12.07.2020 18:28
Var a,b,min,max,f:integer;
begin
readln(a,b);
min:=a+b;
max:=a*b;
if a>b then f:=1 else f:=2;
case f of
1: begin  a:=max; b:=min end; 
2: begin a:=min; b:=max end;
end;
writeln(a,b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота