В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
bestaminova111
bestaminova111
14.09.2022 11:52 •  Информатика

составьте программу заполнения и вывода на экран целочисленного массива а из десяти элементов, каждый из которых равен: своему индексу и квадрат инлекса

Показать ответ
Ответ:
Lisa030105
Lisa030105
18.09.2020 02:20

def print_digit_sum(a):

 print(f'Сумма цифр числа {a} равна {sum([int(i) for i in str(a)])}')

while True:

 try:

   print_digit_sum(int(input('Введите целое число:')))

   break

 except ValueError:

   print('Неверный формат входных данных')

sum([int(i) for i in str(a)]) - здесь мы выполняем следующие действия:

1. Преобразуем число в строку с str(a)

2. Пробегаемся по символам строки от первого до последнего и создаём массив, преобразуя каждый строковый символ в число - [int(i) for i in str(a)]

3. Ну и наконец с оператора sum вычисляем сумму всех элементов получившегося массива

0,0(0 оценок)
Ответ:
yanazyaka
yanazyaka
18.01.2023 22:21

#include <iostream>  

#include <string>  

#include <conio.h>

 

   #define ESC 27

 

using namespace std;

 

int main() {

   char ch;

   int sum = 0;

   do {

       ch = _getch();

       if (ch == ESC) {

           cout << "Output of the program:\n" << sum;

           putchar('\n');

       } else {

           cout << ch;

           sum += (int)ch;

           putchar('\n');

       }

   } while (ch != ESC);

   system("pause");

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота