В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ТвойВраг
ТвойВраг
24.09.2020 06:42 •  Информатика

Составьте программу, запрашивающую 4-х значное число. и выходящую на экран сообщение : "тысяч_, сотен_, десятков_, единиц_".применяя функции деления (div и mod) 2.составьте программу делящую переменную а=100 на 3. деление прекратить когда остаток а будет меньше 3. подсчитать количество вариантов деления и вынести значение на экран.

Показать ответ
Ответ:
daniar16
daniar16
01.10.2020 20:41
1.
var s,a,b,c,d:integer;
begin
readln(s);
a:=s div 1000;
b:=s div 100 mod 10;
c:=s div 10 mod 10;
d:=s mod 10;
writeln('Тысяч ',a,' Сотен ',b,' Десятков ',c,' Единиц ',d);
end.

2.
var k,a:integer;
begin
a:=100;
while a>=3 do begin
a:=a div 3;
k:=k+1;
end;
writeln(k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота