В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
pecheintsynak
pecheintsynak
14.04.2023 22:33 •  Информатика

Составьте в паскаль с while. на каждом следующем дне рождения винни пух съедает столько же меда, сколько съел на двух предыдущих вместе. на двух первых днях рождения у пятачка и кролика он съел по 100 г меда. определите, сколько килограммов меда он съест на десятом дне рождения.

Показать ответ
Ответ:
Неизвестная002
Неизвестная002
07.09.2020 13:49
Числа Фибоначчи (вместо 1 только 100)!
var m1,m2,s,i:integer;
begin
m1:=100; m2:=100;
for i:=3 to 10 do
 begin
 s:=m1+m2;
 m1:=m2;
 m2:=s;
 end;
writeln(s);
end.

Результат:
5500
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота