В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Совсем недавно в Мытищинской Школе программистов было учреждено отделение для биологов. Разумеется, биологам очень неудобно работать в обычных компьютерных классах, поэтому они выбрали наименее занятый кабинет и организовали там инкубатор для новых штаммов микроорганизмов. За долгие годы в кабинетах МШП сформировалась своя уникальная экосистема, которая уже включает в себя определенное количество видов. Биологам известно, что в первый год нашей эры на месте, где через два тысячелетия будет стоять школа №26, уже существовало N штаммов микроорганизмов, а в каждый следующий год их количество увеличивалось ещё в N раз. Руководство хотело бы знать, сколько штаммов микроорганизмов обитает в кабинетах МШП на данный момент. Но поскольку ответ на эту задачу очень велик (N2019), то найдите хотя бы последнюю цифру в записи этого числа. Формат входных данных

В первой строке вводится N — натуральное число, не превосходящее 109.

Формат выходных данных

Требуется вывести последнюю цифру числа N 2019.

входные данныевыходные данные165406341 1 999923 7​

Показать ответ
Ответ:
gavrikovakateri
gavrikovakateri
20.05.2023 07:40
Ищем информационный вес одной ьуквы в первом алфавите;
Для этого представим кол-во ьукв в алфавите в степени числа два
16=2^4 => i= 4 бита

Так же для второго:
256 = 2^8 =>i= 8бит

Кол-во символов одиннаковое, составим отношение алфавитных подходов
(K)
n*i/ n * i. n сокращаем.
8/4= 2 Разница в два раза.

Для письменной работы:
Дано:
K1=K2
N1=16
N2=256

I1/I2-?

Решение:
N=2^i
16=2^4 => i= 4 бита
256 = 2^8 =>i= 8бит

I(Инф. обьес всего файла)= K*i

I1/I2= K 1i / K 2i. K сокращаем
1i / 2i
4/8= 2. (Большое на меньшее делить надо)
В два раза кол-во инфооиации во втором тексте больше, чем в первом
0,0(0 оценок)
Ответ:
Albert116
Albert116
10.03.2020 16:03

var j, a, b, n: integer;

label 1;

begin

1: randomize;

  a: = random (9);

  b: = random (9);

  write (a, '*', b, '=');

  read (n);

  if n = (a * b) then writeln ('відповідь вірний! ')

            else writeln ('відповідь неправильний! ');

  writeln ('продовжуватимеш? ');

  writeln ('якщо так то натисни 1');

  writeln ('якщо немає то натисни 2');

  read (j);

  if j = 1 then goto 1;

  if j = 2 then writeln ('до побачення! ');

end.

начебто так, точно не пам'ятаю.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота