В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
marisshechka1
marisshechka1
31.08.2021 01:17 •  Информатика

Создать файл целых чисел f1. написать программу, заполняющую файл f2 элементами файла f1, значения которых больше «3,7». вывести на экран файл f2. c++

Показать ответ
Ответ:
bobkovaolesya
bobkovaolesya
27.06.2022 01:25

ответ:

векторное изображение - это тип изображения, которое состоит из объектов, описанных . свойства этой фигуры не будут изменяться при увеличении, поскольку фигура состоит из кривых. каждая точка этой фигуры имеет свои координаты, на этом фигура и основана, то есть заданы координаты точек, а между ними могут быть расположены различные кривые. их "искривленность" зависит от свойств точек. кривые могут иметь только цвет и толщину.

плюсы векторных изображений:

- гибкая масштабируемость, можно изменять размеры изображений без потери его визуальных качеств;

- максимальная точность построенного изображения (координаты точек, между которыми могут быть проведены кривые, могут иметь точность до сотых доль микрона) ;

- файл с векторным изображением имеет гораздо меньший размер по сравнению с растровым изображением;

- рисунок имеет высокое качество при печати, особенно это хорошо заметно на хороших принтерах при качественной печати;

- возможность редактирования всех частей векторного изображения;

- простой экспорт векторного рисунка в растровый.

минусы векторных изображений:

- отсутствие реалистичности у векторных рисунков. реалистичность достигается путем применения различных сложных цветовых схем;

- невозможность использования эффектов, которые можно применять в растровой графике;

- практически полная невозможность экспорта растрового рисунка в векторный;

растровое изображение - это изображение, в основе которого стоит таблица. ячейки таблицы - это пикселы. пиксел - это еденица измерения размеров растрового изображения. один пиксел - это одна клеточка в растровом изображении. соответственно растровые изображения состоят из пикселов, только они настолько малы, что в нормальном виде их трудно разлечить. каждый пиксел растрового изображения имеет следующие свойства: цвет и координаты расположения пиксела.

плюсы растрового изображения:

- высокая реалистичность изображения;

- на растровом изображении может быть изображено все, что угодно: как снимок с фотокамеры, так и нарисованное на компьютере изображение;

- к растровым изображениям можно применять самые разнообразные эффекты;

- растровые форматы рисунков используются при создании вэб-страниц в интернете;

недостатки растровых изображений:

- растровые изображения плохо масштабируются, можно уменьшить изображение, однако увеличить его без потери качества невозможно (к потери качества относиться заметное увеличение размытия изображения после увеличения рисунка) ;

- нельзя разбить растровое изображение на части и редактировать их;

- файл с растровым изображением имеет больший размер по сравнению с векторным.

0,0(0 оценок)
Ответ:
rauf2007
rauf2007
19.03.2020 12:02

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

var current, past, sum: real;

    i, n: integer;

begin

  current : = 10;

  for i : = 1 to 10 do begin

    writeln(i, ' ', current);

    past : = current;

    current : = current * 1.1;

  end;

  current : = 10; sum : = 0;

  write('n = ');

  read(n);

  for i : = 1 to n do begin

    sum : = sum + current;

    past : = current;

    current : = current * 1.1;

  end;

  writeln('за ', n, ' дней: ', sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота