Создать массив о работниках из пяти записей следующего вида табельный номер (2 байта), фамилия (25 байт), пол (1 байт), количество детей (1 байт). написать программу на языке ассемблер которая помещает в стек табельные номера работников женщин имеющих детей
Первая и вторая цифры нечетные - False
Вторая или третья цифра четная - True
Последняя цифра четная или нечетная - True
Не четвертая цифра делится на 5 - True
Объяснение:
345678
3 - нечетная цифра;4 - четная цифра.Первая и вторая цифры нечетные - False, так как должны быть истинны оба высказывания.
345678
4 - четная цифра;5 - нечетная цифра.Вторая или третья цифра четная - True, так как должно быть истинно одно из высказываний
345678
8 - четная цифра.Последняя цифра четная или нечетная - True, так как должно быть истинно одно из высказываний
345678
Не четвертая цифра делится на 5 - True, так как на 5 делится третья цифра
program ab;
var
a, b: integer;
begin
write('Введите значения A и B: ');
read(a, b);
writeln('Квадрат величины A: ', sqr(a));
writeln('Квадратный корень величины A: ', sqrt(a));
writeln('Целая часть при делении двух целых величин A и B: ', a div b);
writeln('Остаток от деления при делении двух целых величин A и B: ', a mod b);
end.
Объяснение:
program ab; // Название программы
var
a, b: integer; // Целочисленные переменные для хранения значений
begin // Начало программы
write('Введите значения A и B: '); // Вывод сообщения
read(a, b); // Считываем значения переменных с клавиатуры
writeln('Квадрат величины A: ', sqr(a)); // Вычисляем квадрат переменной A
writeln('Квадратный корень величины A: ', sqrt(a)); // Вычисляем квадратный корень переменной A
writeln('Целая часть при делении двух целых величин A и B: ', a div b); // Вычисляем целую часть при делении двух целых величин A и B
writeln('Остаток от деления при делении двух целых величин A и B: ', a mod b); // Вычисляем остаток от деления при делении двух целых величин A и B
end. // Конец программы