В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
bcfujd19
bcfujd19
24.06.2020 15:16 •  Информатика

Создать программу на алгоритмическом языке в которой будут вводится 2 переменные, значение одной будет показывать сколько раз будет повторяться цикл счётчик, а другая на сколько будет увеличиваться третья переменная S на каждом шаге цикла. Переменная S перед выполнением цикла равна 0. Программа выводит значение переменной S.

Показать ответ
Ответ:
Влад00811
Влад00811
27.09.2020 01:03

Код ниже.

Объяснение:

Для подсчета длины отрезка, нужно знать 4 координаты. А(x;y) и B(x;y).

По формуле L = √(X²+Y²) = √ ((Xb-Xa)²+(Yb-Ya)²) мы можем подсчитать длину любого отрезка по известным координатам.

Код:

import math

a = input('Входные данные: ')

s = a.split(' ')

print("Выходные данные: ",math.sqrt(math.pow(float(s[2]) - float(s[0]),2)+math.pow(float(s[3]) - float(s[1]),2)))

Импортируем модуль math для упрощения жизни и себе и людям. Задаем переменную к которой присваиваем значения введенные с клавиатуры в таком формате (Xa(пробел)Ya(пробел)Xb(пробел)Yb(пробел)) например у нас есть 2 точки А с координатами (1;2) и B(3;4) тогда ввод будет такой: "1 2 3 4"

Дальше преобразуем строку в список с разделителем "пробел"

И дальше идет формула, которую записал выше. Float вместо Int потому что значения могут быть с плавающей точкой.

0,0(0 оценок)
Ответ:
Regardless777
Regardless777
25.03.2021 20:51

Решение Pascal

Delphi/Pascal

program Case5;

var

 N,A,B:Integer;

begin

 Write('Введите номер действия: ');

 Readln(N);

 Write('Введите число A: ');

 Readln(A);

 Write('Введите число B: ');

 Readln(B);

 

 Case N of

   1: Writeln(A+B);

   2: Writeln(A-B);

   3: Writeln(A*B);

   4: Writeln(A/B);

 end;

end.

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

program Case5;

var

 N,A,B:Integer;

begin

 Write('Введите номер действия: ');

 Readln(N);

 Write('Введите число A: ');

 Readln(A);

 Write('Введите число B: ');

 Readln(B);

 

 Case N of

   1: Writeln(A+B);

   2: Writeln(A-B);

   3: Writeln(A*B);

   4: Writeln(A/B);

 end;

end.

 

Решение C

C

#include <stdio.h>

 

int main(void)

{

  system("chcp 1251");

  int n;

  float a,b;

  printf("N:") ;

  scanf ("%i", &n);

  printf("A:") ;

  scanf ("%f", &a);

  printf("B:") ;

  scanf ("%f", &b);

 

  switch (n) {

  case 1:

      printf("%f\n",a+b) ;

      break;

  case 2:

      printf("%f\n",a-b) ;

      break;

  case 3:

      printf("%f\n",a*b) ;

      break;

  case 4:

      printf("%f\n",a/b) ;

      break;

  }

  return 0;

}

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

#include <stdio.h>

 

int main(void)

{

  system("chcp 1251");

  int n;

  float a,b;

  printf("N:") ;

  scanf ("%i", &n);

  printf("A:") ;

  scanf ("%f", &a);

  printf("B:") ;

  scanf ("%f", &b);

 

  switch (n) {

  case 1:

      printf("%f\n",a+b) ;

      break;

  case 2:

      printf("%f\n",a-b) ;

      break;

  case 3:

      printf("%f\n",a*b) ;

      break;

  case 4:

      printf("%f\n",a/b) ;

      break;

  }

  return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота