В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Создайте функцию которая считает с клавиатуры символьный массив и затем рассчитывает количество символов во введенной строке. напишите программу, которая позволяет с пользованием созданной функции считаnь с клавиатуры строку и вывести на экран количество символов в ней (с++)

Показать ответ
Ответ:
Котёнок0007
Котёнок0007
07.10.2020 20:28
#include <iostream>

using namespace std;

void countChars() {
    char s[256];
    cout << "Введите строку: ";
    cin.getline(s, 256);

    int count = 0;
    for (unsigned int i = 0; i < strlen(s); i++)
        count++;
   
    cout << "Количество символов в строке: " << count << endl;
}

int main() {
    setlocale(LC_ALL, "Russian");
    countChars();
    system("pause");
    return 0;
}

//
// или так
//

#include <iostream>

using namespace std;

int countChars(char* s) {
    int count = 0;
    for (unsigned int i = 0; i < strlen(s); i++)
        count++;
    return count;
}

int main() {
    setlocale(LC_ALL, "Russian");
    char s[256];
    cout << "Введите строку: ";
    cin.getline(s, 256);
    cout << "Количество символов в строке: " << countChars(s) << endl;
    system("pause");
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота