Создайте программы в паскале : с клавиатуры вводится целое число x. • выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). • определите, количество делителей числа x не считая 1 и самого числа. • определите, является ли введенное число простым. • напиши программу, которая выведет на экран простые числа в диапазоне от n до m. n и m – целые числа, которые вводятся с клавиатуры.
Var
x, i: integer;
begin
Write('Введите X -> ');
readln(x);
Write(1, ' ');
for i:= 2 to x div 2 + 1 do
if x mod i = 0 then
Write(i, ' ');
Write(x);
end.
2)
Var
x,count, i: integer;
begin
Write('Введите X -> ');
readln(x);
for i:= 2 to x div 2 + 1 do
if x mod i = 0 then
count:= count + 1;
Writeln(count);
end.
3)
Var
x, count, i: integer;
begin
Write('Введите X -> ');
readln(x);
for i:= 2 to x div 2 + 1 do
if x mod i = 0 then
count:= count + 1;
if count = 0 then Writeln('Простое')
else Writeln('Составное');
end.
4)
Var
n,m, i, j: integer;
fl:boolean;
begin
Readln(n,m);
For i:= n to m do
begin
fl := true;
for j:= 2 to i div 2 + 1 do
if i mod j = 0 then fl := false;
if (fl) then Write(i, ' ');
end;
end.