В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
bilainфом
bilainфом
06.04.2023 21:36 •  Информатика

Спитоном такая: написать программу которая вводит 3 числа и выводит "да" если числа являются членами прогрессии, и выводит "нет" если не являются

Показать ответ
Ответ:
kotnapnewme123p04tz4
kotnapnewme123p04tz4
08.09.2022 05:50
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var s:='ДОСТОПРИМЕЧАТЕЛЬНОСТЬ';
  //      1 3 5 7 9 1 3 5 7 9 1
  //       2 4 6 8 + 2 4 6 8 +
  var n:=Length(s);
  var w:=Concat(Copy(s,6,5),s[4],s[12]); Write(w,' ');
  w:=Concat(s[7],s[12],Copy(s,1,2),Copy(s,n-2,3)); Write(w,' ');
  w:=Copy(s,11,6); Insert(Concat(s[8],s[4]),w,2); Write(w,' ');
  w:=Copy(s,9,8); Insert(Concat(s[8],s[4]),w,4); Delete(w,4,1);
  Write(w,' ');
  w:=Concat(Copy(s,13,2),s[4],s[7],s[12],s[1],s[n]); Write(w,' ');
  w:=Concat(Copy(s,6,5),s[7]); Write(w,' ');
  w:=Concat(s[3],Copy(s,11,2),Copy(s,n-2,3),s[10]); Writeln(w)
end.

Результат
ПРИМЕТА РАДОСТЬ ЧИТАТЕЛЬ МЕЧТАТЕЛЬ ТЕТРАДЬ ПРИМЕР СЧАСТЬЕ
0,0(0 оценок)
Ответ:
Дашакот2345681
Дашакот2345681
08.09.2022 05:50
ОЗУ-быстрая, полупроводниковая, энергозависимая память. В ОЗУ хранятся исполняемая в данный момент программа и данные, с которыми она непосредственно работает. Это значит, что когда вы запускаете какую-либо компьютерную программу, находящуюся на диске, она копируется в оперативную память, после чего процессор начинает выполнять команды, изложенные в этой программе. Часть ОЗУ, называемая "видеопамять", содержит данные, соответствующие текущему изображению на экране. При отключении питания содержимое ОЗУ стирается.
Быстродействие (скорость работы) компьютера напрямую зависит от величины его ОЗУ, которое в современных компьютерах может доходить до 128 Мбайт. В первых моделях компьютеров оперативная память составляла не более 1 Мбайт. Современные прикладные программы часто требуют для своего выполнения не менее 4 Мбайт ОЗУ; в противном случае они просто не запускаются.
ОЗУ - это память, используемая как для чтения, так и для записи информации. При отключении электропитания информация в ОЗУ исчезает (энергозависимость) .
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота